Uva679 Dropping Balls

A number of K balls are dropped one by one from the root of a fully binary tree structure FBT. Each time the ball being dropped first visits a non-terminal node. It then keeps moving down, either follows the path of the left subtree, or follows the path of the right subtree, until it stops at one of the leaf nodes of FBT. To determine a ball‘s moving direction a flag is set up in every non-terminal node with two values, either false or true. Initially, all of the flags are false. When visiting a non-terminal node if the flag‘s current value at this node is false, then the ball will first switch this flag‘s value, i.e., from the false to the true, and then follow the left subtree of this node to keep moving down. Otherwise, it will also switch this flag‘s value, i.e., from the true to the false, but will follow the right subtree of this node to keep moving down. Furthermore, all nodes of FBT are sequentially numbered, starting at 1 with nodes on depth 1, and then those on depth 2, and so on. Nodes on any depth are numbered from left to right.

For example, Fig. 1 represents a fully binary tree of maximum depth 4 with the node numbers 1, 2, 3, ..., 15. Since all of the flags are initially set to be false, the first ball being dropped will switch flag‘s values at node 1, node 2, and node 4 before it finally stops at position 8. The second ball being dropped will switch flag‘s values at node 1, node 3, and node 6, and stop at position 12. Obviously, the third ball being dropped will switch flag‘s values at node 1, node 2, and node 5 before it stops at position 10.

Fig. 1: An example of FBT with the maximum depth 4 and sequential node numbers.

Now consider a number of test cases where two values will be given for each test. The first value is D, the maximum depth of FBT, and the second one is I, the Ith ball being dropped. You may assume the value of I will not exceed the total number of leaf nodes for the given FBT.

Please write a program to determine the stop position P for each test case.

For each test cases the range of two parameters D and I is as below:

Input

Contains l+2 lines.

 Line 1 I the number of test cases
Line 2  test case #1, two decimal numbers that are separatedby one blank
...
Line k+1  test case #k Line l+1  test case #l Line l+2 -1 a constant -1 representing the end of the input file 

Output

Contains l lines.

 Line 1 		 the stop position P for the test case #1
...
Line k the stop position P for the test case #k
...
Line l the stop position P for the test case #l

Sample Input

5
4 2
3 4
10 1
2 2
8 128
-1

Sample Output

12
7
512
3
255题目大意:给你一个D层深的树,I个小球,每个小球从根节点开始走,一开始向左走,以后的球走到这个点都走与前一个到这个点的球的相反的方向,求最后每个球的位置编号.分析:一开始看着是一道很水的模拟题,直接模拟一下每次怎么走,判判方向就好了,可是由于数据量太大了,会超时。      其实很容易就能发现规律了,每个球到当前点的方向取决于它是第几个到这个点的,如果是奇数,就往左边走,否则就往右边走,那么我们直接处理最后一个球就好了,那么如果走左子树,那么它就是第(I+1)/2个到达的,否则就是I/2个到达的。
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <cmath>

using namespace std;

int T,D,I,res = 1;

int main()
{
    scanf("%d", &T);
    while (T--)
    {
        res = 1;
        scanf("%d%d", &D, &I);
        for (int i = 1; i <= D - 1; i++)
        {
            if (I % 2 == 1)
            {
                res *= 2;
                I = (I + 1) / 2;
            }
            else
            {
                res = res * 2 + 1;
                I /= 2;
            }
        }
        printf("%d\n", res);
    }

    return 0;
}
 
时间: 2024-08-19 12:25:06

Uva679 Dropping Balls的相关文章

UVA679 Dropping Balls【二叉树结点编号】

Dropping Balls A number of K balls are dropped one by one from the root of a fully binary tree structure FBT. Each time the ball being dropped first visits a non-terminal node. It then keeps moving down, either follows the path of the left subtree, o

UVa679 Dropping Balls (二叉树)

链接:http://acm.hust.edu.cn/vjudge/problem/19499分析:二叉树的递归定义:二叉树要么为空,要么有根节点.左子树和右子树组成,而左右子树分别是一棵二叉树.本题来说,对于一个根节点,当奇数次小球到达时,小球往左走,k*=2,且当前到达左子树小球个数是到达根节点小球个数的(I+1)/2,当偶数次小球到达此根节点时,小球往右走,k=k*2+1,然后当前往右边走到达右子树根结点的小球总个数为I/=2,就这样递归进行直到到达叶子结点. 1 #include <cst

UVA679 - Dropping Balls 题解

这道题显然可以直接模拟前 \(I\) 个小球的掉落,最终即可得解.但是,很明显,这么做会使时间复杂度直接爆炸成 \(O(l\times D\times I)\),已然是力不从心. 仔细观察,可以简单地发现:我们只需模拟第 \(I\) 个小球的运动即可,通过判断当前节点上已经经过了的小球数的奇偶性,可以轻松判断第 \(I\) 个小球的运动路线(这句话是整道题解题方法的精髓,请仔细理解后看下面的代码). Code: #include <bits/stdc++.h> using namespace

679 - Dropping Balls

Dropping Balls PS:因为该题排版较麻烦,这里给出OJ网址:UVa679 - Dropping Balls 有一棵二叉树,最大深度为D,且所有叶子的深度都相同.所有结点从上到下从左到右编号为1, 2, 3,-, 2D-1.在结点1处放一个小球,它会往下落.每个内结点上都有一个开关,初始全部关闭,当每次有小球落到一个开关上时,状态都会改变.当小球到达一个内结点时,如果该结点上的开关关闭,则往左走,否则往右走,直到走到叶子结点,如图6-2所示. 一些小球从结点1处依次开始下落,最后一个

UVa679:Dropping Balls

Dropping Balls A number of K balls are dropped one by one from the root of a fully binary tree structure FBT. Each time the ball being dropped first visits a non-terminal node. It then keeps moving down, either follows the path of the left subtree, o

[2016-02-08][UVA][679][Dropping Balls]

UVA - 679 Dropping Balls Time Limit: 3000MS Memory Limit: Unknown 64bit IO Format: %lld & %llu Submit Status Description A number of K balls are dropped one by one from the root of a fully binary tree structure FBT. Each time the ball being dropped f

Dropping Balls UVA - 679(二叉树的遍历)

题目链接:https://vjudge.net/problem/UVA-679 题目大意:t组样例,每组包括D M   层数是D   问第M个小球落在哪个叶子节点?    每个节点有开关  刚开始全都是关闭的,小球走到节点  节点开关变为与当前相反   每个小球从根节点释放 思路:这题是第一道二叉树遍历的题目,二叉树暴力模拟的确可以求出答案 ,但是很不幸,会超时 然后另一种方法,只需要求第M次小球就行了!  怎么求呢?   试想一下,如果M为奇数 那么从根节点开始看,肯定是往左走(M+1)/2次

UVA - 679 Dropping Balls 规律

题目大意:给出一棵完全二叉树,每个节点上都有一个开关,刚开始开关都是开的,球经过该节点后开关就关上了(根节点除外).如果球经过该节点的兄弟节点,那么该节点的开关就又开了 现在往根节点放球,优先选择左边的节点走,如果左边的节点的开关关了,就选择右边的.球落到叶节点后就继续另一颗球,问第n颗球落到了哪个叶节点上 解题思路:其实这题蛮水的,因为是二叉树,所以可以由球的奇偶行来判断球往哪个分支走,如果n % 2 == 0就表示第n颗往右边走了,反之就是往左边走了,以此类推即可推出最后一颗球落到哪了 #i

Dropping Balls

#include<bits/stdc++.h> using namespace std; int D, N; int main() { while (scanf("%d%d", &D, &N)!=EOF) { int k = 1; for (int i = 0; i < D - 1; i++) { if (N % 2) { k = k * 2; N = (N + 1) / 2; } else { k = k * 2 + 1; N /= 2; } } p