HDU - 4788 Hard Disk Drive (成都邀请赛H 水题)

HDU - 4788

Hard Disk Drive

Time Limit:1000MS   Memory Limit:32768KB   64bit IO Format:%I64d & %I64u

[Submit]  [Go Back]  [Status]

Description

  Yesterday your dear cousin Coach Pang gave you a new 100MB hard disk drive (HDD) as a gift because you will get married next year.

  But you turned on your computer and the operating system (OS) told you the HDD is about 95MB. The 5MB of space is missing. It is known that the HDD manufacturers have a different capacity measurement. The manufacturers think 1 “kilo” is 1000 but the OS thinks
that is 1024. There are several descriptions of the size of an HDD. They are byte, kilobyte, megabyte, gigabyte, terabyte, petabyte, exabyte, zetabyte and yottabyte. Each one equals a “kilo” of the previous one. For example 1 gigabyte is 1 “kilo” megabytes.

  Now you know the size of a hard disk represented by manufacturers and you want to calculate the percentage of the “missing part”.

Input

  The first line contains an integer T, which indicates the number of test cases.

  For each test case, there is one line contains a string in format “number[unit]” where number is a positive integer within [1, 1000] and unit is the description of size which could be “B”, “KB”, “MB”, “GB”, “TB”, “PB”, “EB”, “ZB”, “YB” in short respectively.

Output

  For each test case, output one line “Case #x: y”, where x is the case number (starting from 1) and y is the percentage of the “missing part”. The answer should be rounded to two digits after the decimal point.

Sample Input

 2
100[MB]
1[B]
        

Sample Output

 Case #1: 4.63%
Case #2: 0.00%

Hint


思路:主要的差别是在第一位
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;

int n;
char u[8];

int main()
{
	while (scanf("%d", &n) != EOF) {
		for (int cas = 1; cas <= n; cas++) {
			scanf("%*d%s", u);
			printf("Case #%d: ", cas);
			if (u[1] == 'B')
				printf("0.00");
			else if (u[1] == 'K')
				printf("2.34");
			else if (u[1] == 'M')
				printf("4.63");
			else if (u[1] == 'G')
				printf("6.87");
			else if (u[1] == 'T')
				printf("9.05");
			else if (u[1] == 'P')
				printf("11.18");
			else if (u[1] == 'E')
				printf("13.26");
			else if (u[1] == 'Z')
				printf("15.30");
			else if (u[1] == 'Y')
				printf("17.28");
			printf("%%\n");
		}
	}
	return 0;
}

HDU - 4788 Hard Disk Drive (成都邀请赛H 水题)

时间: 2024-11-25 11:00:02

HDU - 4788 Hard Disk Drive (成都邀请赛H 水题)的相关文章

HDU 4788 Hard Disk Drive

题目链接:HDU 4788 Hard Disk Drive 题面: Hard Disk Drive Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 1872    Accepted Submission(s): 1028 Problem Description Yesterday your dear cousin Coach Pang

HDU 4788 Hard Disk Drive(数学)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4788 Problem Description Yesterday your dear cousin Coach Pang gave you a new 100MB hard disk drive (HDD) as a gift because you will get married next year. But you turned on your computer and the operati

HDU 4788 Hard Disk Drive (2013成都H,水题) 进位换算

1 #include <stdio.h> 2 #include <algorithm> 3 #include <string.h> 4 #include<cmath> 5 using namespace std; 6 double a; 7 char s[100]; 8 int fun(char s[]) { 9 if(strcmp(s,"B]") == 0)return 0; 10 if(strcmp(s,"KB]"

hdu 1012:u Calculate e(数学题,水题)

u Calculate e Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 28686    Accepted Submission(s): 12762 Problem Description A simple mathematical formula for e iswhere n is allowed to go to infinit

HDU 5135 Little Zu Chongzhi&#39;s Triangles(简单水题)

题目链接: 戳我 题目大意: 给一堆 木棍,用这些木棍组成三角形,要组成的所有的三角形的面积和最大,不一定要用完所有的木棍. 样例解释: 3 //三个棍子 1 1 20   // 每个棍子的长度,自然,这三个棍子不可能组成三角形,故输出 0.00 7          // 7个棍子 3 4 5 3 4 5 90 // 组成两个三角形(3, 3 4)和(4, 4, 5),面积和即为13.64 0   // 输出 0 退出 解题思路: 本来不想写题解的,因为太水了,,,,,,, 可是看到 谷歌搜出

HDU 5131 Song Jiang&#39;s rank list(水题)

Song Jiang's rank list Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others) Total Submission(s): 259    Accepted Submission(s): 134 Problem Description <Shui Hu Zhuan>,also <Water Margin>was written by Shi Nai'

HDOJ 4788 Hard Disk Drive

Python3打表.... Hard Disk Drive Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 1044    Accepted Submission(s): 564 Problem Description Yesterday your dear cousin Coach Pang gave you a new 100MB

HDU 5099 Comparison of Android versions(坑水题)

C - Comparison of Android versions HDU 5099 Time Limit: 1000 MS Memory Limit: 32768 KB 64-bit integer IO format: %I64d , %I64u Java class name: Main [Submit] [Status] Description As an Android developer, itˇs really not easy to figure out a newer ver

HDU 5328(2015多校4)-Problem Killer(水题)

题目地址:HDU 5328 题意:在一个长度为n的序列中取出连续的k个数,让这k个数组成等差数列或者等比数列,问这样的k最大可以是多少. Ps:注意用double搞,因为等比数列求公比相除可能为小数. #include <stdio.h> #include <math.h> #include <string.h> #include <stdlib.h> #include <iostream> #include <sstream> #i