组合数学 - 母函数的运用 + 模板 --- hdu : 2082

找单词

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4093    Accepted Submission(s): 2933

Problem Description

假设有x1个字母A, x2个字母B,..... x26个字母Z,同时假设字母A的价值为1,字母B的价值为2,..... 字母Z的价值为26。那么,对于给定的字母,可以找到多少价值<=50的单词呢?单词的价值就是组成一个单词的所有字母的价值之和,比如,单词ACM的价值是1+3+14=18,单词HDU的价值是8+4+21=33。(组成的单词与排列顺序无关,比如ACM与CMA认为是同一个单词)。

Input

输入首先是一个整数N,代表测试实例的个数。
然后包括N行数据,每行包括26个<=20的整数x1,x2,.....x26.

Output

对于每个测试实例,请输出能找到的总价值<=50的单词数,每个实例的输出占一行。

Sample Input

2
1 1 1 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
9 2 6 2 10 2 2 5 6 1 0 2 7 0 2 2 7 5 10 6 10 2 10 6 1 9

Sample Output

7
379297

Source

2006/1/15 ACM程序设计期末考试



Mean:

analyse:

经典的母函数运用题。

Time complexity:O(n^3)

Source code:

// Memory   Time
// 1347K     0MS
// by : Snarl_jsb
// 2014-09-18-13.40
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<iostream>
#include<vector>
#include<queue>
#include<stack>
#include<map>
#include<string>
#include<climits>
#include<cmath>
#define N 1000010
#define LL long long
using namespace std;

int cnt[100],c1[100],c2[100];
int main()
{
    ios_base::sync_with_stdio(false);
    cin.tie(0);
//    freopen("C:\\Users\\ASUS\\Desktop\\cin.cpp","r",stdin);
//    freopen("C:\\Users\\ASUS\\Desktop\\cout.cpp","w",stdout);
    int Cas;
    cin>>Cas;
    while(Cas--)
    {
        for(int i=1;i<=26;++i)
            cin>>cnt[i];
        memset(c1,0,sizeof(c1));   //以防后面越界,最好全部赋值为0
        memset(c2,0,sizeof(c2));
        for(int i=0;i<=cnt[1]&&i<=50;++i)
            c1[i]=1;
        for(int i=2;i<=26;++i)
        {
            for(int j=0;j<=50;++j)
            {
                for(int k=0;k+j<=50&&k<=cnt[i]*i;k+=i)
                {
                    c2[k+j]+=c1[j];
                }
            }
            for(int j=0;j<=50;++j)
            {
                c1[j]=c2[j];
                c2[j]=0;
            }
        }
        long long ans=0;
        for(int i=1;i<=50 ;++i)
            ans+=c1[i];
        cout<<ans<<endl;
    }
    return 0;
}

  

时间: 2024-08-29 14:03:39

组合数学 - 母函数的运用 + 模板 --- hdu : 2082的相关文章

组合数学 - 母函数的运用 --- 模板题

Holding Bin-Laden Captive! Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 15064    Accepted Submission(s): 6750 Problem Description We all know that Bin-Laden is a notorious terrorist, and he h

HDU 2082 找单词 --- 母函数

HDU 2082 找单词 起码通过这题,知道了母函数是什么东西,值得一做. /* HDU 2082 找单词 --- 母函数 */ #include <cstdio> #include <cstring> const int N = 50; int num[30], c1[N + 10], c2[N + 10]; int main() { #ifdef _LOCAL freopen("D:\\input.txt", "r", stdin); /

hdu 2082 找单词(母函数|多重背包)

http://acm.hdu.edu.cn/showproblem.php?pid=2082 每一个字母的价值固定,但数目不定.所以每个字母对应的表达式也不同,若第i个字母的个数为a[i],价值为i,那么它的母函数为(1+x^i+x^(2i)+.....+x^(a[i]*b[i])).那么将i属于[1,26]的母函数相乘得到的x^m(1<=m<=50)的系数相加就是答案. #include <stdio.h> #include <iostream> #include &

hdu 2082 母函数

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2082 找单词 Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 4035    Accepted Submission(s): 2887 Problem Description 假设有x1个字母A, x2个字母B,..... x26个字母Z,

fft模板 HDU 1402

1 // fft模板 HDU 1402 2 3 #include <iostream> 4 #include <cstdio> 5 #include <cstdlib> 6 #include <algorithm> 7 #include <vector> 8 #include <math.h> 9 #include <memory.h> 10 #include <bits/stdc++.h> 11 using

母函数的基本模板讲解

母函数的基本代码模板 自己理解:对于(#式)  (1+x+x^2+x^3+x^4+x^5+....)*(1+x^2+x^4+x^6+x^8+x^10+....)*(1+x^3+x^6+x^9+x^12....)..... 第一个for给c1 和 c2 赋值 , 把上面#式的第一个括号(1+x+x^2+x^3+x^4+x^5+....)的系数给放在c1中, 从而再次计算从 # 的 第二个括号开始 , 所以 i 就是代表的# 式第几个括号, 而 用程序模拟手工计算 , 就是 先计算第一个括号 与 第

HDU 2082 母函数模板题

生成函数,英文是Generating Function.恕本人不才,本文只介绍生成函数的其中一种用法. 生成函数是说,构造这么一个多项式函数g(x),使得x的n次方系数为f(n). 对于母函数,我看到最多的是这样两句话: 1.“把组合问题的加法法则和幂级数的乘幂对应起来.” 2.“把离散数列和幂级数一 一对应起来,把离散数列间的相互结合关系对应成为幂级数间的运算关系,最后由幂级数形式来确定离散数列的构造. “ 其实这两句话我也不算太懂.先放这里,说不定以后可能会慢慢理解吧. 还是先举个大牛博客中

hdu 2082 找单词(母函数)

找单词 Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 4971    Accepted Submission(s): 3537 Problem Description 假设有x1个字母A, x2个字母B,..... x26个字母Z,同时假设字母A的价值为1,字母B的价值为2,..... 字母Z的价值为26.那么,对于给定的字母,可以找

组合数学 - 母函数 --- 模板 + 详解

Square Coins Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 8341    Accepted Submission(s): 5674 Problem Description People in Silverland use square coins. Not only they have square shapes but