UVA 657-The die is cast(dfs*2)

The die is cast

Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu

Submit Status

Description

InterGames is a high-tech startup company that specializes in developing technology that allows users to play games over the Internet. A market analysis has alerted them to the fact that
games of chance are pretty popular among their potential customers. Be it Monopoly, ludo or backgammon, most of these games involve throwing dice at some stage of the game.

Of course, it would be unreasonable if players were allowed to throw their dice and then enter the result into the computer, since cheating would be way to easy. So, instead, InterGames
has decided to supply their users with a camera that takes a picture of the thrown dice, analyzes the picture and then transmits the outcome of the throw automatically.

For this they desperately need a program that, given an image containing several dice, determines the numbers of dots on the dice.

We make the following assumptions about the input images. The images contain only three dif- ferent pixel values: for the background, the dice and the dots on the dice. We consider two pixels connected if
they share an edge - meeting at a corner is not enough. In the figure, pixels A and B are connected, but B and C are not.

A set S of pixels is connected if for every pair (a,b) of pixels in S, there is a sequence  in S such
that a = a1 and b = ak , and ai and ai+1 are connected for .

We consider all maximally connected sets consisting solely of non-background pixels to be dice. `Maximally connected‘ means that you cannot add any other non-background pixels to the set
without making it dis-connected. Likewise we consider every maximal connected set of dot pixels to form a dot.

Input

The input consists of pictures of several dice throws. Each picture description starts with a line containing two numbers w and h, the width and height of the picture, respectively. These values satisfy .

The following h lines contain w characters each. The characters can be: ``.‘‘ for a background pixel, ``*‘‘ for a pixel of a die, and ``X‘‘ for
a pixel of a die‘s dot.

Dice may have different sizes and not be entirely square due to optical distortion. The picture will contain at least one die, and the numbers of dots per die is between 1 and 6, inclusive.

The input is terminated by a picture starting with w = h = 0, which should not be processed.

Output

For each throw of dice, first output its number. Then output the number of dots on the dice in the picture, sorted in increasing order.

Print a blank line after each test case.

Sample Input

30 15
..............................
..............................
...............*..............
...*****......****............
...*X***.....**X***...........
...*****....***X**............
...***X*.....****.............
...*****.......*..............
..............................
........***........******.....
.......**X****.....*X**X*.....
......*******......******.....
.....****X**.......*X**X*.....
........***........******.....
..............................
0 0

Sample Output

Throw 1
1 2 2 4

题意:给一张有很多个(至少一个)骰子的图片,判断骰子上的点数。这张图片有三种像素组成,分别是 ‘ . ‘表示背景, ‘ * ‘表示骰子, ‘ X ‘骰子中的点;两个像素共用一条边表示连接,而共用一角却不表示连接。

解题思路:两次深度搜索,先搜索筛子,再搜索筛子中有几个点。

PS:控制边界的时候少打了个等于号,wa了一天,挖槽,我的眼睛是有多瞎!saddddddd

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <algorithm>
#include <set>
#include <queue>
#include <stack>

using namespace std;
char mp[110][110];
int sum[110];
int n,m,t;
int jx[]={1,0,-1,0};
int jy[]={0,-1,0,1};
void dfs1(int x,int y)
{
    int i;
    mp[x][y]='*';//找到X的时候直接将他变成*,这样就不用用vis标记,同时也不会重复计算相邻的X
    for(i=0;i<4;i++){
        int dx=x+jx[i];
        int dy=y+jy[i];
        if(dx>=0&&dx<m&&dy>=0&&dy<n&&mp[dx][dy]=='X'){
            dfs1(dx,dy);
        }
    }
}
void dfs2(int x,int y)
{
    int i;
    mp[x][y]='.';//找到X和*之间将他们变成.,少了重复计算的步骤
    for(i=0;i<4;i++){
        int dxx=x+jx[i];
        int dyy=y+jy[i];
        if(dxx>=0&&dxx<m&&dyy>=0&&dyy<n&&mp[dxx][dyy]=='X'&&mp[dxx][dyy]!='.'){
            dfs1(dxx,dyy);
            sum[t]++;
        }
        if(dxx>=0&&dxx<m&&dyy>=0&&dyy<n&&mp[dxx][dyy]=='*'&&mp[dxx][dyy]!='.')
            dfs2(dxx,dyy);
    }
}
int main()
{
    int icase=1;
    int i,j;
    while(~scanf("%d %d",&n,&m)){
        if(n==0&&m==0)  break;
        memset(sum,0,sizeof(sum));
        memset(mp,'.',sizeof(mp));
        t=0;
        for(i=0;i<m;i++)
        scanf("%s",mp[i]);
        for(i=0;i<m;i++)
        for(j=0;j<n;j++){
            if(mp[i][j]=='*'){
                dfs2(i,j);
                t++;
            }
        }
        sort(sum,sum+t);
        printf("Throw %d\n", icase++);
        for(i=0;i<t-1;i++)
            printf("%d ",sum[i]);
        printf("%d\n",sum[i]);
        printf("\n");
    }
    return 0;
}
时间: 2024-12-28 10:17:34

UVA 657-The die is cast(dfs*2)的相关文章

uva 657 - The die is cast

  The die is cast  InterGames is a high-tech startup company that specializes in developing technology that allows users to play games over the Internet. A market analysis has alerted them to the fact that games of chance are pretty popular among the

UVA 657-The die is cast(双重BFS)

InterGames is a high-tech startup company that specializes in developing technology that allows users to play games over the Internet. A market analysis has alerted them to the fact that games of chance are pretty popular among their potential custom

uva 219 - Department of Redundancy Department(dfs+剪枝)

题目链接:uva 219 - Department of Redundancy Department 题目大意:给定一些关系,问哪一些关系是可以被替代的,如果可以被替代,给出替代的方案,一种即可. 解题思路:因为总共也就26个字母,所以用二进制数表示状态.剪枝,每次将所有可选关系均考虑进去都无法满足则是false. #include <cstdio> #include <cstring> #include <algorithm> using namespace std;

Uva657 - The die is cast

原题链接https://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=598 这题就是在一堆*里找X,相邻的X算一个,所以我们可以两次dfs搜索,dfs2搜*有多少堆,dfs2搜一堆*里面有多少个不同的X,然后在按升序把每个堆里面的不同X输出来= = #include<stdio.h> #include<string.h> #in

UVa 657 掷色子

题意:就是有一张大图,每个像素即格子只可能是 . * X 三种,分别代表背景.色子.色子的点数.两个格子是相邻的或连通的,当且仅当两个格子是*或X,且有公共边,即上下左右四个方向,对角不算,即四连块.将一个连通块看做一个色子,将这个连通块中的X的连通块个数看做该色子的点数. 思路:两次深搜.第一次是由*和X来深搜每个连通块,在深搜每个连通块时由X来深搜X的连通块个数.这里可以通过两个标记数组visit来表示是否访问过,visitx来表示是否访问深搜X过.(也可以将X改为*.*改为.的方式实现,不

UVA 572 Oil Deposits油田(DFS求连通块)

UVA 572     DFS(floodfill)  用DFS求连通块 Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u Description Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M

UVA - 524 Prime Ring Problem(dfs回溯法)

UVA - 524 Prime Ring Problem Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu Description A ring is composed of n (even number) circles as shown in diagram. Put natural numbers  into each circle separately, and the sum of number

uva 11008 Antimatter Ray Clearcutting(DFS + 记忆化搜索)

uva 11008 Antimatter Ray Clearcutting It's year 2465, and you are the Chief Engineer for Glorified Lumberjacks Inc. on planet Trie. There is a number of trees that you need to cut down, and the only weapon you have is a high-powered antimatter ray th

UVA How Big Is It? (DFS+回溯)

 How Big Is It?  Ian's going to California, and he has to pack his things, including his collection of circles. Given a set of circles, your program must find the smallest rectangular box in which they fit. All circles must touch the bottom of the bo