poj 2082 Terrible Sets (数据结构 ——栈 STL)



Terrible Sets

Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 2999   Accepted: 1549

Description

Let N be the set of all natural numbers {0 , 1 , 2 , . . . }, and R be the set of all real numbers. wi, hi for i = 1 . . . n are some elements in N, and w0 = 0.

Define set B = {< x, y > | x, y ∈ R and there exists an index i > 0 such that 0 <= y <= hi ,∑0<=j<=i-1wj <= x <= ∑0<=j<=iwj}

Again, define set S = {A| A = WH for some W , H ∈ R+ and there exists x0, y0 in N such that the set T = { < x , y > | x, y ∈ R and x0 <= x <= x0 +W and y0 <= y <= y0 + H} is contained in set B}.

Your mission now. What is Max(S)?

Wow, it looks like a terrible problem. Problems that appear to be terrible are sometimes actually easy.

But for this one, believe me, it‘s difficult.

Input

The input consists of several test cases. For each case, n is given in a single line, and then followed by n lines, each containing wi and hi separated by a single space. The last line of the input is an single integer
-1, indicating the end of input. You may assume that 1 <= n <= 50000 and w1h1+w2h2+...+wnhn < 109.

Output

Simply output Max(S) in a single line for each case.

Sample Input

3
1 2
3 4
1 2
3
3 4
1 2
3 4
-1

Sample Output

12
14

Source

Shanghai 2004 Preliminary

最近几天出去玩去了,都没做题,也没发博客了,今天做题感觉也没什么状态了。。做题状态还是要保持好啊,所以今天就对一些基本的数据结构练习一些,对STL不怎么熟悉,就练习一些STL,找找状态,栈的基本操作还是要搞懂!!

参考《ACM/ICPC算法训练教程上的代码》,思路讲解可以看看http://www.cnblogs.com/hxsyl/archive/2012/08/16/2643015.html

题意就是给你一些紧贴着x轴的相互挨着的矩形,给定每个矩形的长宽,问他们可以形成的最大的矩形是多少?

大概的思路就是,用栈来做,如果矩形的高度是递增的,就让它入栈,如果即将入栈的高度小于栈顶元素的高度,就出栈,退到保持递增,在出栈的过程中统计到递增的可以达到的高度的最大面积,记录矩形的总长度。

每次读入一个矩形,若它比栈顶元素还高就直接进栈,否则不断将栈中元素弹栈,直到当前栈顶元素能够与读入的矩形满足高度递增。弹栈过程中累加弹出的元素的宽度,然后每弹出一个就判断当前弹出元素的高度x累加的宽度能否更新最大面积ans。然后以新的矩形作高,已经弹出栈的元素总宽度加上新矩形宽度作宽,把这个矩形插入到栈里。

最终栈肯定是一个单调的,只需要再把栈一个个弹空,弹栈过程中仍像上面那样计算即可。

下面是ac的代码:

#include <iostream>
#include <stack>
#include <cstdio>
using namespace std;
struct rectangle  //矩形的结构体
{
    int h;
    int w;
}data;
int main()
{
    int n,ans,prior_h,total_w,area;
    while(scanf("%d",&n)&&n!=-1)
    {
        ans=0;
        stack<rectangle>s; //定义一个空栈
        prior_h=0; //上次进栈的矩形高度
        for(int i=0;i<n;i++)
           {
            scanf("%d%d",&data.w,&data.h);
        if(data.h>prior_h)
        {
            s.push(data);
        }
        else
        {
            total_w=0; //总宽度
            area=0;  //当前面积
            while(!s.empty()&&s.top().h>data.h)
            {
                total_w+=s.top().w; 
                area=total_w*s.top().h;
                if(area>ans)
                    ans=area;
                s.pop();
            }
            total_w+=data.w;
            data.w=total_w;
            s.push(data); //新矩形进栈
        }
       prior_h=data.h;
    }
    total_w=0;
    area=0;
    while(!s.empty())
    {
        total_w+=s.top().w;
        area=total_w*s.top().h;
        if(area>ans)
            ans=area;
        s.pop();
    }
    printf("%d\n",ans);
    }
    return 0;
}

poj 2082 Terrible Sets (数据结构 ——栈 STL),布布扣,bubuko.com

时间: 2024-11-07 22:34:11

poj 2082 Terrible Sets (数据结构 ——栈 STL)的相关文章

POJ 2082 Terrible Sets

Terrible Sets Time Limit: 1000MS   Memory Limit: 30000K Total Submissions: 5325   Accepted: 2713 Description Let N be the set of all natural numbers {0 , 1 , 2 , . . . }, and R be the set of all real numbers. wi, hi for i = 1 . . . n are some element

stack(单调栈) POJ 2082 Terrible Sets

题目传送门 题意:紧贴x轴有一些挨着的矩形,给出每个矩形的长宽,问能组成的最大矩形面积为多少 分析:用堆栈来维护高度递增的矩形,遇到高度小的,弹出顶部矩形直到符合递增,顺便计算矩形面积,且将弹出的宽度都累积到当前的矩形中,这样最后再扫描一遍,算面积很方便,这题应该算是 POJ 2559 的强化版了 收获:stack的应用,求矩形面积,矩阵相乘,表达式计算 代码: /************************************************ * Author :Running

POJ 2082 题解

Terrible Sets Time Limit: 1000MS   Memory Limit: 30000K Total Submissions: 5330   Accepted: 2715 Description Let N be the set of all natural numbers {0 , 1 , 2 , . . . }, and R be the set of all real numbers. wi, hi for i = 1 . . . n are some element

POJ2082 Terrible Sets

Terrible Sets Time Limit: 1000MS   Memory Limit: 30000K Total Submissions: 5067   Accepted: 2593 Description Let N be the set of all natural numbers {0 , 1 , 2 , . . . }, and R be the set of all real numbers. wi, hi for i = 1 . . . n are some element

数据结构-栈、队列和链表

一.栈stack 是后进先出的数据结构 栈顶指针指的始终是栈最上方元素的一个标记,即放在最上面的元素.栈顶元素为空时令top为-1. 在使用pop()函数和top()函数时,需要使用empty()判断栈是否为空. 在STL中stack容器来编写代码,STL定义stack的复杂度是O(1). 常见函数: clear() size() empty() push() pop() top() 二.队列queue 是一种先进先出的数据结构 需要一个队首指针front来指向队首元素的前一个位置,而使用一个队

南阳OJ-2 括号配对 (数据结构-栈的应用)

括号配对问题 时间限制:3000 ms  |  内存限制:65535 KB 难度:3 描述 现在,有一行括号序列,请你检查这行括号是否配对. 输入 第一行输入一个数N(0<N<=100),表示有N组测试数据.后面的N行输入多组输入数据,每组输入数据都是一个字符串S(S的长度小于10000,且S不是空串),测试数据组数少于5组.数据保证S中只含有"[","]","(",")"四种字符 输出 每组输入数据的输出占一行,

Terrible Sets

Time Limit: 1000MS   Memory Limit: 30000K Total Submissions: 3017   Accepted: 1561 Description Let N be the set of all natural numbers {0 , 1 , 2 , . . . }, and R be the set of all real numbers. wi, hi for i = 1 . . . n are some elements in N, and w0

数据结构——栈——寻找下一个较大元素

题目描述 给出一个数组,向右寻找每一个元素的下一个较大的元素,没有更大的则为-1 举例 {4,6,1,3,2,5} 则求得的答案应为 {6,-1,3,5,5,-1} 题目分析 首先对于这样的题目,我们总是先想到最简单的,那么就是枚举,每次循环一个元素,不停的向右找就可以了.时间复杂度应该是n^2 但是这样肯定是不够用的. 然后我们考虑,这道题我们实际上遇到的问题是什么? 其实简单的说,这道题的意思是,在变化的数组中找到下一个较大的值. 难点在于,数组元素的变化,以及不是找最大值,而是找下一个较大

C数据结构-栈和队列,括号匹配举例

1.栈和队列是两种特殊的线性表 运算操作被限定只能在表的一端或两端插入,删除元素,故也称它们为限定的线性表结构 2.栈的基本运算 1).Stackinit(&s) 构造一个空栈 2).Stackempty(s) 判断s是否为空栈,当s为空栈时,函数返回值1 否则 0 3).Push(&s,x)  在栈s 的顶部插入元素x,简称将x入 栈 4).Pop(&s,&x) 在栈s 中删除顶元并将其值保存在x单元中返回,简称将x出栈 5)Gettop(s,&x)  读s栈中的