ARM-Linux开机自启动设置-ok6410开发板

hdu 1163 Eddy‘s digital Roots

Problem Description

The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is
repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process
must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

The Eddy‘s easy problem is that : give you the n,want you to find the n^n‘s digital Roots.

Input

The input file will contain a list of positive integers n, one per line. The end of the input will be indicated by an integer value of zero. Notice:For each integer in the input n(n<10000).

Output

Output n^n‘s digital root on a separate line of the output.

Sample Input

2
4
0

Sample Output

4
4

Author

eddy

/***********************

看FFT看的头晕还是没看懂,然后回头刷水题,想找点快感,没想到碰到个小炸弹。。。

用到了一个九余数定理,不知道这个定理确实很难做……

九余数定理简介:一个数N  各位数字的和 对9 取余等于 这个数对 9取余。。

太坑了,记下来,免得以后忘了……

**********************/

#include <iostream>
#include <stdio.h>
using namespace std;
int main()
{
    int n,i,s;
    while(scanf("%d",&n)&&n)
    {
        s = 1;
        for(i = 1;i<=n;i++){
            s=s*n%9;
        }
        if(s==0)    printf("9\n");
        else    printf("%d\n",s);
    }
    return 0;
}

太坑了……

ARM-Linux开机自启动设置-ok6410开发板,布布扣,bubuko.com

时间: 2024-10-26 19:11:25

ARM-Linux开机自启动设置-ok6410开发板的相关文章

linux下数据库实例开机自启动设置

linux下数据库实例开机自启动设置 1.修改/oratab [[email protected] ~]# vi/etc/oratab     --把N改为Y,如下提示 # This file is used by ORACLEutilities.  It is created by root.sh # and updated by the Database ConfigurationAssistant when creating # a database. # A colon, ':', is

Linux下oracle开机自启动设置

今天在虚拟机安装完oracle数据库重启系统后想进入数据库却发现如下错误: 出现ORA-01034和ORA-27101的原因是多方面的:主要是oracle当前的服务不可用,shared memory realm does not exist,是因为oracle没有启动或没有正常启动.那么如何在Linux启动时自动启动Oracle监听和实例呢? 首先尝试使用oracle启动数据库的命令dbstart,可是发现又报错如下错误: ORACLE_HOME_LISTNER is not SET, unab

linux开机自启动服务优化设置命令

1.设置成英文字符,避免出现乱码[[email protected] ~]# LANG=en2.两种配置linux开机自启动服务命令:1)[[email protected] ~]# ntsysv2)[[email protected] ~]# setup3.查看文本模式3级别下的开机自启动服务[[email protected] ~]# chkconfig --list|grep 3:onabrt-ccpp           0:off 1:off 2:off 3:on 4:off 5:on

linux下数据库实例监听开机自启动设置

linux下数据库实例监听开机自启动设置 2016/5/16 zhanky 脚本介绍 在开始之前,我们先介绍一下几个会用到的脚本. oratab oratab文件是在创建数据库实例时建立的,在安装时使用root用户执行root.sh脚本后得到.(如果忘记也可以直接手动创建.) 在$ORACLE_HOME/bin目录下的$ORACLE_HOME/bin/dbstart和$ORACLE_HOME/bin/dbshut需要调用/etc/oratab文件,如果不存在,dbstart和dbshut将失败,

OK6410开发板系统安装---嵌入式回归第二篇

1. 嵌入式系统需要被安装到开发板的nandflash上 或者 SD卡上 2. 需要安装的嵌入式Linux系统可以分三个部分 1> Bootloader 启动OS 3> 放应用程序 .用户文件 .配置文件 3. 把嵌入式Linux系统安装到Nandflash的具体步骤? 这里先采用左边dd命令/windows烧写软件方式 1. 将标准SD卡通过卡槽插到笔记本上 2. 快速格式化SD卡 3. 烧写启动安装程序 我的今天烧写的时候也出现了这个问题.之前学校的台式机一直用的很顺!百度了这个方法然后就

移植Mplayer到OK6410开发板

移植Mplayer到OK6410开发板 作者:vasage 项目需要,需要将Mplayer移植到开发板上,所以今天花了一下下午成功移植,其中参考很多文档,后发现许多文档陈旧,些许文档有少量错误,所以这里整理一下放出来.经过测试,avi.mp3等音视频播放流畅,运行正常,下面就是移植过程,给大家做参考.测试步骤我觉得没必要放上来,请见谅.作者lcc76161113,欢迎转载. 编译器:arm-linux-gcc(4.3.2)     Pc平台:ubuntu 在移植之前有必要先说明一下几个问题:  

OK6410开发板启动过程(详细信息)

硬件平台:OK6410开发板 KK U-Boot 1.1.6 (Sep 19 2014 - 10:00:03) for SMDK6410 **************************************** ** u-boot 1.1.6 ** ** Updated for OK6410 TE6410 Board ** ** Version (2012-09-23) ** ** OEM: Forlinx Embedded ** ** Web: http://www.witech.co

制作SD(8G)卡Linux镜像,使得ZC706开发板可以从SD卡启动进入Linux系统

转自网络,供学习记录使用,红色部分是我实验时,这篇文章和网站稍有出入的地方. 目的:制作SD(8G)卡Linux镜像,使得ZC706开发板可以从SD卡启动进入Linux系统 在http://wiki.analog.com/resources/eval/user-guides/ad-fmcomms2-ebz/quickstart/zynq(姑且把这个链接成为链接1吧)链接中找到 图1 点击绿色字体的链接,下载镜像原始文件.这里有不同时期的版本,本说明中选择 图2 下载的原始文件为:2014_R2-

Linux下Nginx、PHP、MySQL、Redis开机自启动设置

一.Nginx开机启动设置 1.在/etc/init.d/目录下创建脚本 vi /etc/init.d/nginx 2.更改脚本权限 chmod 775 /etc/init.d/nginx 3.编写脚本内容 #! /bin/shset -ePATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/binDESC="nginx daemon"NAME=nginxDAEMON=/usr/local/nginx/sbin/$N