cisco静态路由

1.1静态路由基本配置

1.1.1实验目的:

为路由器配置静态路由,从而了解路由发上的过程。

1.1.2实验拓扑:

1.1.3实验配置:

R2的配置:

interface Loopback0

ip address 2.2.2.2 255.255.255.0

interface Serial0/2

ip address 26.26.26.2 255.255.255.0

ip route 3.3.3.0 255.255.255.0 26.26.26.6

ip route 6.6.6.0 255.255.255.0 26.26.26.6

ip route 36.36.36.0 255.255.255.0 26.26.26.6

R6的配置:

 interface Loopback0

 ip address 6.6.6.6 255.255.255.0

 interface Serial0/2

 ip address 26.26.26.6 255.255.255.0

 interface Serial0/3

 ip address 36.36.36.6 255.255.255.0

ip route 2.2.2.0 255.255.255.0 26.26.26.2

ip route 3.3.3.0 255.255.255.0 36.36.36.3

R3的配置:

interface Loopback0

 ip address 3.3.3.3 255.255.255.0

interface Serial0/3

 ip address 36.36.36.3 255.255.255.0

ip route 2.2.2.0 255.255.255.0 36.36.36.6

ip route 6.6.6.0 255.255.255.0 36.36.36.6

ip route 26.26.26.0 255.255.255.0 36.36.36.6

1.1.4验证:

查看路由表,并PING每个路由器的回环接口。

R2

R2#show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

   2.0.0.0/24 is subnetted, 1 subnets

C       2.2.2.0 is directly connected, Loopback0

     3.0.0.0/24 is subnetted, 1 subnets

S       3.3.3.0 [1/0] via 26.26.26.6

     36.0.0.0/24 is subnetted, 1 subnets

S       36.36.36.0 [1/0] via 26.26.26.6

     6.0.0.0/24 is subnetted, 1 subnets

S       6.6.6.0 [1/0] via 26.26.26.6

     26.0.0.0/24 is subnetted, 1 subnets

C       26.26.26.0 is directly connected, Serial0/2

R2#ping 6.6.6.6

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 6.6.6.6, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 28/53/132 ms

R2#ping 3.3.3.3

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 68/92/144 ms

R6

R6#show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

 

     2.0.0.0/24 is subnetted, 1 subnets

S       2.2.2.0 [1/0] via 26.26.26.2

     3.0.0.0/24 is subnetted, 1 subnets

S       3.3.3.0 [1/0] via 36.36.36.3

     36.0.0.0/24 is subnetted, 1 subnets

C       36.36.36.0 is directly connected, Serial0/3

     6.0.0.0/24 is subnetted, 1 subnets

C       6.6.6.0 is directly connected, Loopback0

     26.0.0.0/24 is subnetted, 1 subnets

C       26.26.26.0 is directly connected, Serial0/2

R6#ping 2.2.2.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 8/46/92 ms

R6#ping 3.3.3.3

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 32/61/116 ms

R3

R3#show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

 

     2.0.0.0/24 is subnetted, 1 subnets

S       2.2.2.0 [1/0] via 36.36.36.0

     3.0.0.0/24 is subnetted, 1 subnets

C       3.3.3.0 is directly connected, Loopback0

     36.0.0.0/24 is subnetted, 1 subnets

C       36.36.36.0 is directly connected, Serial0/3

     6.0.0.0/24 is subnetted, 1 subnets

S       6.6.6.0 [1/0] via 36.36.36.6

     26.0.0.0/24 is subnetted, 1 subnets

S       26.26.26.0 [1/0] via 36.36.36.0

R3#ping 2.2.2.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 28/78/136 ms

R3#ping 6.6.6.6

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 6.6.6.6, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 16/57/140 ms

1.2静态路由(2)

1.2.1实验目的:

在全网互访的基础上,实现R2的2.2.2.2可以访问R3的3.3.3.3。但R2的26.26.26.2不可以访问R3的3.3.3.3。

1.2.2实验拓扑:

1.2.3实验配置:

R2的配置:

interface Loopback0

ip address 2.2.2.2 255.255.255.0

interface Serial0/2

ip address 26.26.26.2 255.255.255.0

ip route 3.3.3.0 255.255.255.0 26.26.26.6

ip route 6.6.6.0 255.255.255.0 26.26.26.6

ip route 36.36.36.0 255.255.255.0 26.26.26.6

R6的配置:

 interface Loopback0

 ip address 6.6.6.6 255.255.255.0

 interface Serial0/2

 ip address 26.26.26.6 255.255.255.0

 interface Serial0/3

 ip address 36.36.36.6 255.255.255.0

ip route 2.2.2.0 255.255.255.0 26.26.26.2

ip route 3.3.3.0 255.255.255.0 36.36.36.3

R3的配置:

interface Loopback0

 ip address 3.3.3.3 255.255.255.0

interface Serial0/3

 ip address 36.36.36.3 255.255.255.0

ip route 2.2.2.0 255.255.255.0 36.36.36.6

ip route 6.6.6.0 255.255.255.0 36.36.36.6

ip route2 6.26.26.6 255.255.255.255 36.36.36.6

 

 

1.2.4验证:

R2#ping 3.3.3.3

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

R2#ping 3.3.3.3 sou

R2#ping 3.3.3.3 source 2.2.2.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:

Packet sent with a source address of 2.2.2.2

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 56/81/124 ms

1.3浮动静态路由

1.3.1实验目的:

使用浮动静态路由,实现路由备份。

观察动态路由EIGRP与静态路由之间的转换。

1.3.2实验拓扑:

1.3.3实验配置:

R2的配置:

interface Loopback0

ip address 2.2.2.2 255.255.255.0

interface Serial0/2

ip address 26.26.26.2 255.255.255.0

interface Ethernet1/1

ip address 62.62.62.2 255.255.255.0

router eigrp 90

network 2.0.0.0

network 26.0.0.0

no auto-summary

ip route 6.6.6.0 255.255.255.0 62.62.62.6 100

R6的配置:

interface Loopback0

ip address 6.6.6.6 255.255.255.0

interface Serial0/2

ip address 26.26.26.6 255.255.255.0

interface Ethernet1/1

ip address 62.62.62.6 255.255.255.0

router eigrp 90

network 6.0.0.0

network 26.0.0.0

no auto-summary

ip route 2.2.2.0 255.255.255.0 62.62.62.2 100

1.3.4实验验证:

R6#show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

2.0.0.0/24 is subnetted, 1 subnets

D       2.2.2.0 [90/2297856] via 26.26.26.2, 00:00:20, Serial0/2

6.0.0.0/24 is subnetted, 1 subnets

C       6.6.6.0 is directly connected, Loopback0

26.0.0.0/24 is subnetted, 1 subnets

C       26.26.26.0 is directly connected, Serial0/2

62.0.0.0/24 is subnetted, 1 subnets

C       62.62.62.0 is directly connected, Ethernet1/1

R2#show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

2.0.0.0/24 is subnetted, 1 subnets

C       2.2.2.0 is directly connected, Loopback0

6.0.0.0/24 is subnetted, 1 subnets

D       6.6.6.0 [90/2297856] via 26.26.26.6, 00:00:32, Serial0/2

26.0.0.0/24 is subnetted, 1 subnets

C       26.26.26.0 is directly connected, Serial0/2

62.0.0.0/24 is subnetted, 1 subnets

C       62.62.62.0 is directly connected, Ethernet1/1

R6#traceroute 2.2.2.2

Type escape sequence to abort.

Tracing the route to 2.2.2.2

1 26.26.26.2 88 msec 76 msec *

当把S0/2接口shutdown

R6#show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

2.0.0.0/24 is subnetted, 1 subnets

S       2.2.2.0 [100/0] via 62.62.62.2

6.0.0.0/24 is subnetted, 1 subnets

C       6.6.6.0 is directly connected, Loopback0

62.0.0.0/24 is subnetted, 1 subnets

C       62.62.62.0 is directly connected, Ethernet1/1

R6#ping 2.2.2.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 44/74/164 ms

当接口S0/2 no shutdown:

路由表中重新又有了EIGRP学到的路由

R6#show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

2.0.0.0/24 is subnetted, 1 subnets

D       2.2.2.0 [90/2297856] via 26.26.26.2, 00:00:08, Serial0/2

6.0.0.0/24 is subnetted, 1 subnets

C       6.6.6.0 is directly connected, Loopback0

26.0.0.0/24 is subnetted, 1 subnets

C       26.26.26.0 is directly connected, Serial0/2

62.0.0.0/24 is subnetted, 1 subnets

C       62.62.62.0 is directly connected, Ethernet1/1

时间: 2024-10-06 20:33:17

cisco静态路由的相关文章

cisco静态路由-适合初学者

RT1enableconf t /进入全局模式banner motd #this is a ccna1# /设置旗标banner login #this is a ccna1#int f0/0 /进入接口ip add 172.16.20.1 255.255.255.0 /接口配ip地址int f0/1ip add 172.16.10.1 255.255.255.0eixtip route 172.16.30.0 255.255.255.0 172.16.20.2 /配置路由信息,30网段的地址指

Cisco动态路由(rip)

接Cisco静态路由,讨论一下Cisco动态路由. 实验环境布置 命令布置动态路由 Router0: Router>enable Router#configure terminal Router(config)#interface fastEthernet 0/0 Router(config-if)#no shutdown Router(config-if)#ip address 192.168.1.2 255.255.255.0 Router(config-if)#exit Router(co

Cisco PT模拟实验(12) 路由器静态路由的配置

Cisco PT模拟实验(12) 路由器静态路由的配置 实验目的: 掌握静态路由的配置方法和应用 掌握路由选择表中的路由描述 熟悉路由选择和分组转发的原理及过程 实验背景: 某公司除总部外,另有一处分部,并且都有一个独立的局域网,为了使公司各部之间能相互通信,共享资源.每个出口利用一台路由器进行连接,两台路由器间公司申请了一条DDN专线(数字数据网)进行相连,要求做适当配置实现相互访问. 技术原理: 路由器属于网络层设备,能够根据IP数据报的首部信息,选择一条最佳路径(这一过程称为"路由选择&q

配置Cisco 路由器的静态路由

之前我们通过几篇博文方向了路由器的基础信息配置的方法.大家也应该掌握了IT民工所具备的四大技能:开得了设备,接得了线路,设得了地址,ping得了IP.今天咱们来看一下静态路由如何设置,如何让不同地址段的地址互通. 根据拓图扑通所给出的信息,我们为三台路由器的端口配置好IP地址. 配置好端口的IP 地址后,在Yong1上做如下操作, 不成功,原因是路由表中没有到达192.168.2.0网段的信息 什么是路由表,我们可以在路由器上用show ip route 命令来看一下路由表的内容 'C代表的是直

Cisco基础--VLan、静态路由、默认路由综合实验

纪念一下2014年11月26日晚.学校爆发大规模的病毒,集体恶心,上吐下泻.好吧,我不幸也中枪了.昨晚顶着高烧写完的,写完后一看断网了,只能今早誊写在博客中了.小伙伴们可千万不要吃垃圾食品了.健康才是最重要的哦. 拓扑图: 实验要求及步骤: 1.根据图中的IP地址,合理规划各设备接口和PC的IP地址: 2.校园网按照图示划分VLAN,各VLAN通过三层交换机SVI实现通信:另外三层交换机F0/24口开启三层功能并配置IP地址. 3.在网络设备SW1,R3上配置静态路由,在R2上配置默认路由,实现

CISCO CCNA 静态路由

由于网络的需求,大部分网络需要两台路由及两台以上.此时当客户机访问目标网络需跨越多个路由时就需要网络管理员在各路由器上去配置路由协议.而静态路由协议往往配置在网络较小而且不易变动的小规模网络中. 路由就是把信息从源传输到目的地的行为.信息包就可以是看作是一个代,而路由就可以说是一张地图,路由表即为行走的路径.静态路由是管理员手动一条一条的配置,路由器之间不会相互学习路由表.当网络的拓扑结构或链路的状态发生变化时,网络管理员需要手工去修改路由表中相关的静态路由信息.静态路由信息在缺省情况下是私有的

通过思科模拟器CISCO PACKET TRACER学习网络7——静态路由

两个不同区域的网络若想实现通信,需要在路由器上配置路由来实现网络中的终端收发跨本网络的数据包 路由器可以连接多个网络,但是路由器本身并不知道其它网络的信息,这时我们需要手动配置静态路由让路由器知道其他网络信息或者配置动态路由让路由器自己学习其他网络的信息. 本次学习配置静态路由 配置思路 1配置路由器下联交换机的物理接口,开启端口并配置IP地址 2配置PC的IP地址,并设置网关为交换机上联路由器的物理接口地址 3配置路由器之间连接的物理接口,开启端口并配置IP地址 4新建两台路由器的静态路由条目

Cisco Packet Tracer 静态路由配置

一.拓扑图 二.配置PC.路由器 PC0: PC1: route0: Router>enRouter#conf tRouter(config)#hostname route0route0(config)#int f0/0route0(config-if)#ip ad 192.168.10.1 255.255.255.0route0(config-if)#no shroute0(config)#int s2/0route0(config-if)#ip ad 192.168.20.1 255.255

Cisco路由交换CCNP中级课程-实验2:静态路由下一跳与出接口配置

实验环境介绍:52LAB自主设计制作的实验操作环境以及实验要求,方便CCNP学习者系统性的学习和实验操作,提高学习效率,降低学习成本. 实验要求:1.按照拓扑图上显示信息给每台路由器配置主机名和IP地址:2.52LAB-1路由器上不要配置任何路由协议:3.52LAB-2路由器到172.16.2.0/24网络使用静态路由(使用出接口配置):4.52LAB-4路由器配置静态默认路由协议:5.测试a:52LAB-1与52LAB-2路由器分别ping 52LAB-4路由器(记录测试结果):6.关闭52L