A registration card number of PAT consists of 4 parts:
the 1st letter represents the test level, namely, T for the top level, A for advance and B for basic;
the 2nd – 4th digits are the test site number, ranged from 101 to 999;
the 5th – 10th digits give the test date, in the form of yymmdd;
finally the 11th – 13th digits are the testee’s number, ranged from 000 to 999.
Now given a set of registration card numbers and the scores of the card owners, you are supposed to output the various statistics according to the given queries.
Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers N (≤10
?4
?? ) and M (≤100), the numbers of cards and the queries, respectively.
Then N lines follow, each gives a card number and the owner’s score (integer in [0,100]), separated by a space.
After the info of testees, there are M lines, each gives a query in the format Type Term, where
Type being 1 means to output all the testees on a given level, in non-increasing order of their scores. The corresponding Term will be the letter which specifies the level;
Type being 2 means to output the total number of testees together with their total scores in a given site. The corresponding Term will then be the site number;
Type being 3 means to output the total number of testees of every site for a given test date. The corresponding Term will then be the date, given in the same format as in the registration card.
Output Specification:
For each query, first print in a line Case #: input, where # is the index of the query case, starting from 1; and input is a copy of the corresponding input query. Then output as requested:
for a type 1 query, the output format is the same as in input, that is, CardNumber Score. If there is a tie of the scores, output in increasing alphabetical order of their card numbers (uniqueness of the card numbers is guaranteed);
for a type 2 query, output in the format Nt Ns where Nt is the total number of testees and Ns is their total score;
for a type 3 query, output in the format Site Nt where Site is the site number and Nt is the total number of testees at Site. The output must be in non-increasing order of Nt’s, or in increasing order of site numbers if there is a tie of Nt.
If the result of a query is empty, simply print NA.
Sample Input:
8 4
B123180908127 99
B102180908003 86
A112180318002 98
T107150310127 62
A107180908108 100
T123180908010 78
B112160918035 88
A107180908021 98
1 A
2 107
3 180908
2 999
Sample Output:
Case 1: 1 A
A107180908108 100
A107180908021 98
A112180318002 98
Case 2: 2 107
3 260
Case 3: 3 180908
107 2
123 2
102 1
Case 4: 2 999
NA
-----------------------
注意:使用unordered_map(头文件unordered_map)比map(头文件map)更高效,因为map内存在键值的自动排序;
cmp()函数传参比使用引用的形式效率会更高;
题目大意:
读入n个考生的考生号和分数,执行m个操作:
操作存在三种情况:
case1:输出所有对应级别考试的考生号和分数,按照分数降序,分数相同时考生号升序排列
case2:输出对应考点的考生人数和考场的总分数:
case3:输出对应考试时间的各个考点的考点号和考生数(使用unordered_map更高效,map)
#include<stdio.h> #include<vector> #include<iostream> #include<string> #include<algorithm> #include<unordered_map> #pragma warning(disable:4996) using namespace std; int n, m; struct Node { string t; int score; }; bool cmp(Node &a, Node&b){ return a.score != b.score ? a.score>b.score : a.t<b.t; } int main() { cin >> n >> m; vector<Node>v(n); for (int i = 0; i < n; i++) { cin >> v[i].t >> v[i].score; } for (int i = 1; i <= m; i++) { string s; int num; int tp = 0, tc = 0; cin >> num >> s; printf("Case %d: %d %s\n", i, num, s.c_str()); vector<Node>ans; if (1 == num) { for (int j = 0; j < n; j++) { if (v[j].t[0] == s[0])ans.push_back(v[j]); } } else if (2 == num) { for (int j = 0; j < n; j++) { if (v[j].t.substr(1, 3) == s) { tp++, tc += v[j].score; } } if (tp) { printf("%d %d\n", tp, tc); } } else if (3 == num) { unordered_map<string, int>ss; for (int j = 0; j < n; j++) { if (v[j].t.substr(4, 6) == s)ss[v[j].t.substr(1, 3)]++; } for (auto t : ss)ans.push_back({t.first,t.second}); } if (((1 == num || 3 == num) && 0 == ans.size()) || (2 == num&&0 == tp)) { printf("NA\n"); continue; } sort(ans.begin(), ans.end(), cmp); for (auto ss : ans) { printf("%s %d\n", ss.t.c_str(), ss.score); } } return 0; }
原文地址:https://www.cnblogs.com/zxzmnh/p/11632644.html