queue的使用-Hdu 1702

ACboy needs your help again!

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 16823    Accepted Submission(s): 8254

Problem Description

ACboy was kidnapped!! 
he miss his mother very much and is very scare now.You can‘t image how dark the room he was put into is, so poor :(.
As a smart ACMer, you want to get ACboy out of the monster‘s labyrinth.But when you arrive at the gate of the maze, the monste say :" I have heard that you are very clever, but if can‘t solve my problems, you will die with ACboy."
The problems of the monster is shown on the wall:
Each problem‘s first line is a integer N(the number of commands), and a word "FIFO" or "FILO".(you are very happy because you know "FIFO" stands for "First In First Out", and "FILO" means "First In Last Out").
and the following N lines, each line is "IN M" or "OUT", (M represent a integer).
and the answer of a problem is a passowrd of a door, so if you want to rescue ACboy, answer the problem carefully!

Input

The input contains multiple test cases.
The first line has one integer,represent the number oftest cases.
And the input of each subproblem are described above.

Output

For each command "OUT", you should output a integer depend on the word is "FIFO" or "FILO", or a word "None" if you don‘t have any integer.

Sample Input

4
4 FIFO
IN 1
IN 2
OUT
OUT
4 FILO
IN 1
IN 2
OUT
OUT
5 FIFO
IN 1
IN 2
OUT
OUT
OUT
5 FILO
IN 1
IN 2
OUT
IN 3
OUT

Sample Output

1
2
2
1
1
2
None
2
3

这个题的思路其实也很简单,就是模拟栈和队列,来实现对应的操作,主要是为了熟悉queue的使用

#include <iostream>
#include <queue>
#include <stack>
#include <string>

using namespace std;

int main()
{
    int t,n,temp;
    cin>>t;
    while(t--){
        string str,str1;
        queue<int>Q;
        stack<int>S;
        cin>>n>>str;
        for(int i = 0;i < n; i++){
            if(str=="FIFO"){
                cin>>str1;
                if(str1=="IN"){
                    cin>>temp;
                    Q.push(temp);
                }
                if(str1=="OUT"){
                    if(Q.empty())
                        cout<<"None"<<endl;
                    else{
                        cout<<Q.front()<<endl;
                        Q.pop();
                    }
                }
            }
            else{
                cin>>str1;
                if(str1=="IN"){
                    cin>>temp;
                    S.push(temp);
                }
                if(str1=="OUT"){
                    if(S.empty())
                        cout<<"None"<<endl;
                    else{
                        cout<<S.top()<<endl;
                        S.pop();
                    }
                }
            }
        }
    }
    return 0;
}

原文地址:https://www.cnblogs.com/jingshixin/p/12236855.html

时间: 2024-10-30 03:17:20

queue的使用-Hdu 1702的相关文章

hdu 1702 ACboy needs your help again!

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1702 题目大意:按照所给要求,输出相应的数.“FIFO”指代先进先出,即队列的概念,“FILO”指代先进后出,即栈的表现形式~这里定义两个函数即可,一个队列,一个栈的调用! 1 #include <iostream> 2 #include <cstdio> 3 #include <queue> 4 #include <stack> 5 #include <

HDU 1702 ACboy needs your help again! (栈和队列的模拟)

ACboy needs your help again! Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 3164    Accepted Submission(s): 1655 Problem Description ACboy was kidnapped!! he miss his mother very much and is ve

HDU - 1702 ACboy needs your help again!(栈和队列)

Description ACboy was kidnapped!! he miss his mother very much and is very scare now.You can't image how dark the room he was put into is, so poor :(. As a smart ACMer, you want to get ACboy out of the monster's labyrinth.But when you arrive at the g

HDU 1702 ACboy needs your help again!(附加优先队列)

ACboy was kidnapped!! he miss his mother very much and is very scare now.You can't image how dark the room he was put into is, so poor :(.As a smart ACMer, you want to get ACboy out of the monster's labyrinth.But when you arrive at the gate of the ma

HDU 1702 ACboy needs your help again!(栈 队列 基础)

#include<cstdio> #include<cmath> #include<queue> #include<stack> #include<cstring> #include<iostream> #include<algorithm> using namespace std; int t,n; int main() { int i,j,k; cin>>t; char op[10],io[10]; whi

HDU 1702 ACboy needs your help again! (栈与队列)

ACboy needs your help again! Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 3701    Accepted Submission(s): 1885 Problem Description ACboy was kidnapped!! he miss his mother very much and is v

HDU 1702 http://acm.hdu.edu.cn/showproblem.php?pid=1702

#include<stdio.h> #include<string.h> #include<queue> #include<stack> #define N 10 using namespace std; void Q(int n) { int m; char s[N]; queue<int>Q; while(n--) { scanf("%s", s); if(strcmp(s, "IN") == 0) {

A - ACboy needs your help again! (HDU - 1702)

- 题目大意 给出了先进先出和先进后出的两种结构,分别对应队列和栈,并且每种均给出In和Out两类操作,如果是In,push进后面的数,如果是Out,输出栈顶(队首). - 解题思路 对于给的命令判断,然后来决定是用队列还是栈. - 代码 #include<iostream> #include<stack> #include<queue> using namespace std; int main() { int n,x,b; char a[5]; char c[5];

HDU 1908 Double Queue&lt;Set&gt;

Problem Description The new founded Balkan Investment Group Bank (BIG-Bank) opened a new office in Bucharest, equipped with a modern computing environment provided by IBM Romania, and using modern information technologies. As usual, each client of th