hdu1584 A strange lift (电梯最短路径问题)

A strange lift

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 15570    Accepted Submission(s): 5832

Problem Description

There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button "UP" , you will go up Ki floor,i.e,you will
go to the i+Ki th floor,as the same, if you press the button "DOWN" , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can‘t go up high than N,and can‘t go down lower than 1. For example, there is a buliding with 5 floors,
and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button "UP", and you‘ll go up to the 4 th floor,and if you press the button "DOWN", the lift can‘t do it, because it can‘t go down to the -2 th floor,as you know ,the -2
th floor isn‘t exist.

Here comes the problem: when you are on floor A,and you want to go to floor B,how many times at least he has to press the button "UP" or "DOWN"?

Input

The input consists of several test cases.,Each test case contains two lines.

The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn.

A single 0 indicate the end of the input.

Output

For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can‘t reach floor B,printf "-1".

Sample Input

5 1 5
3 3 1 2 5
0

Sample Output

3

Recommend

8600   |   We have carefully selected several similar problems for you:  1385 1242 pid=1142" style="color:rgb(26,92,200); text-decoration:none">1142 1217 1253

Statistic | 

pid=1548" style="color:rgb(26,92,200); text-decoration:none">Submit | 

problemid=1548" style="color:rgb(26,92,200); text-decoration:none">Discuss | 

pid=1548" style="color:rgb(26,92,200); text-decoration:none">Note

电梯仅仅有两个方向,向上或者向下。既然是求最短路径。也就用到dijkstra算法(无负权值)。

仅仅要能想到怎样构造算法即可。假设自己的算法,却不知道怎样用来解题,也都是没用的。

在这里我想给大家说一下。

在以后做题的过程中,不要仅仅看别人的代码,要看思想,别人为什么这样写。然后依据自己想象的思想写一遍代码。写的过程中不要

看别人的代码。即使不正确也无所谓,这样印象最深,以后也就随手敲来、

详细还是代码里面见:

#include <stdio.h>
#include<string.h>
#include <queue>
using namespace std;
struct node
{
	int pos,t;
	friend bool operator<(node a,node b)
	{
		return a.t>b.t;
	}
};
priority_queue<node>s;
int lift[205],vis[205],n;
int dijkstra(int st,int ed)
{
	node temp,temp1;
	int flag=0;
	temp.pos=st,temp.t=0;
	s.push(temp);
	while(!s.empty())
	{
		temp1=temp=s.top(),s.pop();
		vis[temp.pos]=1;
		if(temp.pos==ed)
		{
			flag=1;
			break;
		}
		temp.pos=temp1.pos-lift[temp1.pos];//
		temp.t=temp1.t+1;
		if(temp.pos>=1&&temp.pos<=n&&!vis[temp.pos])
		s.push(temp);
		temp.pos=temp1.pos+lift[temp1.pos];
		temp.t=temp1.t+1;
		if(temp.pos>=1&&temp.pos<=n&&!vis[temp.pos])
		s.push(temp);//和以往的代码不同的也就这个地方。曾经做的要么是个矩阵,要么是个树,如今就两个方向了。。推断电梯的
这两个方向,进队列即可了
	}
	if(flag)
	return temp.t;
	else
	return -1;
}
int main()
{
	int st,ed;
	while(scanf("%d",&n)!=EOF)
	{
		if(n==0)
		break;
		scanf("%d %d",&st,&ed);
		for(int i=1;i<=n;i++)
		scanf("%d",&lift[i]);
		memset(vis,0,sizeof(vis));
		while(!s.empty())
		s.pop();
		printf("%d\n",dijkstra(st,ed));
	}
	return 0;
} 
时间: 2024-08-17 14:27:03

hdu1584 A strange lift (电梯最短路径问题)的相关文章

HDU1548——A strange lift(最短路径:dijskstra算法)

A strange lift DescriptionThere is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button "U

hdu1548 A strange lift(bfs 或Dijkstra最短路径)

1 #include<iostream> 2 #include<cstdio> 3 #include<algorithm> 4 #include<cstring> 5 #define M 205 6 #define INF 0x3f3f3f3f 7 using namespace std; 8 9 int map[M][M]; 10 int d[M], vis[M]; 11 int n; 12 int b, e; 13 14 void Dijkstra(){

HDU 1548 A strange lift【不错的最短路,spfa】

A strange lift Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 21281    Accepted Submission(s): 7786 Problem Description There is a strange lift.The lift can stop can at every floor as you want

HDU 1548 A strange lift(Dijkstra,简单BFS)

题目大意: 电梯有两个选项向上或向下,每层楼有一个参数ki,代表电梯可以再该楼层的基础上向上或向下移动ki层,限制条件是向上不能超过楼层总数n,向下不能少于一.输入总层数n和当前所在层数以及目标层数,然后是n个数分别代表第i层的移动范围.输出最少移动次数,若不可达,输出-1. 解题思路: 1.用Dijkstra算法,首先构建邻接矩阵,注意在构造时,要考虑i-k[i]<1和i+k[i]>n,i代表当前所在层. 1 #include<string.h> 2 #include<st

HDU 1548 (最基础的BFS了) A strange lift

这是一维的BFS,而且没有什么变形,应该是最基础的BFS了吧 题意: 有这样一个奇葩的电梯,你在第i层的时候你只能选择上或者下Ki层,也就是你只能从第i层到达i+Ki或者i-Ki层.当然电梯最低只能在1层最高只能在n层. 给出起点和终点问最少需要多少次才能到达终点,如果不能到达输出-1 没有什么好解释的了,如此单纯的一道题,只要不是太粗心就能A过去 1 //#define LOCAL 2 #include <iostream> 3 #include <cstdio> 4 #incl

hdu1548 A strange lift (简单bfs)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1548 A strange lift Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 15974    Accepted Submission(s): 5973 Problem Description There is a strange l

HDU 1548 A strange lift(最短路&amp;&amp;bfs)

A strange lift Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 26943    Accepted Submission(s): 9699 Problem Description There is a strange lift.The lift can stop can at every floor as you want,

HDU1548A strange lift(搜索)

A strange lift Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 11649    Accepted Submission(s): 4419 Problem Description There is a strange lift.The lift can stop can at every floor as you want

HDU1548:A strange lift(Dijkstra或BFS)

题目链接 http://acm.hdu.edu.cn/showproblem.php?pid=1548 题意:电梯每层有一个数,例如第n层有个数k, 那么这一层只能上k层或下k层,但是不能低于一层或高于n层, 给定起点与终点,要求出最少要按几次键 我的思路:这题可以用bfs或者用最短路(dijsktra) bfs AC代码 #include<cstdio>#include<iostream>#include<cstring>#include<queue>us